Fork me on GitHub
Fork me on GitHub
Donar Ahora!
Seleccione una cantidad para donar


¿Quiere que su nombre de usuario sea revelado con su donación?
Si - Listeme como un geneoso donante
No - Liste mi donación como un donante anónimo


Usuario
Bienvenido
Haz click para registrarte. Es gratuito y podrás utilizar todos los recursos de la web

Login

Recuerdame

¿Perdió su contraseña?


Online
Conectados: 15
Miembros: 0
Invitados: 5
Buscadores: 10

Estadísticas
Nuevos miembros: [BillyStilw-25/10/2017] [Teacher194-24/10/2017] [TimmyAngel-18/10/2017] [Leblanc-18/10/2017] [HealthyNut-17/10/2017] [HalliePerk-12/10/2017] [ShadBlais-8/10/2017] [WilburCruc-1/10/2017] [Ulanowski7-25/9/2017] [KaleyKlem-23/9/2017]
Registrados: 30176
Hoy: 0
Ayer: 0

Conectados:
usInvitadoNoticias
onlineInvitadoTitulares
onlineInvitadoPerfiles extendidos
onlineInvitado
usInvitadoForos
XOOPS : Xoops 2.3.1 Final
Enviado por wilden el 13/10/2008 10:10:00 (12582 Lecturas)

El equipo de desarrollo de XOOPS tiene el placer de anunciar XOOPS 2.3.1 Final.

Esta versión se centra principalmente en correcciones de errores de XOOPS 2.3.0 de acuerdo con los reportes de la comunidad.

Un par de errores se han solucionado en los scripts de actualización para las versiones 2.2, así como problemas en los accesos a los campos de los perfiles.

La información del modo "debug" a sido ajustada según las peticiones de la comunidad y ahora es posible ajusta a que usuarios nos interesa mostrar dicha información (invitados, registrados o solo a administradores). Esta característica se ajusta en el archivo /xoops_data/configs/xoopsconfig.php.

Descargas
-----------------------------------
Xoops 2.3.1 en ingles

Xoops 2.3.1 en Español ISO

Xoops 2.3.0 a Xoops 2.3.1 Actualización en ingles

Paquete del idioma Español en ISO

Paquete del idioma Español en UTF-8



Requisitos del sistema
-----------------------------------

PHP:
Cualquier versión de PHP >= 4.3 (PHP 4.2.x puede funcionar pero oficualmente no tiene soporte, se recomienda PHP 5.0+)

MySQL:
MySQL server 3.23+ (se recomienda MySQL 5.0+)

Servidor Web:
Cualquier servidor web que soporte la version PHP requerida, (se recomienda Apache)

Instalando XOOPS 2.3.1
-----------------------------------

1. Copiar el contenido de la carpeta htdocs/ a su servidor
2. Cerciórese de que mainfile.php, cache, templates_c y uploads sean escribibles por el servidor
3. Por razones de seguridad, le sugerimos que mueva la carpeta xoops_lib (la carpeta que contiene las bibliotecas de código para XOOPS) y xoops_data (para los datos de XOOPS) fuera de la raíz del sitio, o incluso cambiar los nombres de las carpetas.
4. La carpeta xoops_data/ debe ser escribible; Crea y establezca permisos de escrituras a las siguientes carpetas: xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ y xoops_data/caches/smarty_compile/
5. Acceda a la carpeta donde copió los archivos necesarios para la instalación utilizando su navegador web. Inicie el asistente de instalación

(TRADUCCION PENDIENTE)

We also highly recommend the installation of the PROTECTOR module which will bring additional security protection and logging capabilities to your site.

To install protector module with a fresh new installation of XOOPS 2.3.1, copy /extras/mainfile.dist.php.protector to /htdocs/mainfile.dist.php BEFORE installing XOOPS.
To install protector module with upgrading from a previous version to XOOPS 2.3.1, copy /extras/mainfile.dist.php.protector to /upgrade/upd-2.0.18-to-2.3.0/mainfile.dist.php BEFORE upgrading XOOPS.

Upgrading from a previous version
-----------------------------------

Upgrading from XOOPS 2.3.0 (easy way)
1. Get the update package from the sourceforge file repository
2. Overwrite your existing files with the new ones
3. Move the "upgrade" folder inside the "htdocs" folder (it's been kept out as it's not needed for full installs) on your local machine
4. Access /upgrade/ with a browser, and follow the instructions
5. Follow the instructions to update your database
6. Delete the upgrade folder from your server
7. Update the "system" module from the modules administration interface, other modules, especially "profile" are recommended to update as well


Upgrading from XOOPS 2.0.* above 2.0.14 and 2.2.* (using the full package)
1. Move the "upgrade" folder inside the "htdocs" folder (it's been kept out as it's not needed for full installs) on your local machine
2. Delete htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/extras/, htdocs/template_c/, htdocs/themes/ and htdocs/uploads/ from the "htdocs" folder on your LOCAL machine
3. Upload the content of the htdocs folder on your LOCAL machine over your existing files on your server
4. For security considerations, you are encouraged to move directories xoops_lib (for XOOPS libraries) and xoops_data (for XOOPS data) out of document root, or even change the folder names.
5. Make the directory of xoops_data/ writable; Create and make the directories of xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ and xoops_data/caches/smarty_compile/ writable.
6. Ensure the server can write to mainfile.php
7. Access /upgrade/ with a browser, and follow the instructions
8. Follow the instructions to update your database
9. Write-protect mainfile.php again
10. Delete the upgrade folder from your server
11. Update the "system" module from the modules administration interface, other modules are recommended to update as well


Upgrading from any XOOPS ranging from 2.0.7 to 2.0.13.2 (using the full package):
1. Move the "upgrade" folder inside the "htdocs" folder (it's been kept out as it's not needed for full installs) on your LOCAL machine
2. Delete htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/extras/, htdocs/template_c/, htdocs/themes/ and htdocs/uploads/ from the "htdocs" folder on your LOCAL machine
3. Upload the content of the htdocs folder on your LOCAL machine over your existing files on your server
4. Delete the following folders and files from your server (they belong to an old version):
* class/smarty/core
* class/smarty/plugins/resource.db.php
5. Ensure the server can write to mainfile.php
6. For security considerations, you are encouraged to move directories xoops_lib (for XOOPS libraries) and xoops_data (for XOOPS data) out of document root, or even change the folder names.
7. Make the directory of xoops_data/ writable; Create and make the directories of xoops_data/caches/, xoops_data/caches/xoops_cache/, xoops_data/caches/smarty_cache/ and xoops_data/caches/smarty_compile/ writable.
8. Access /upgrade/ with a browser, and follow the instructions
9. Write-protect mainfile.php again
10. Delete the upgrade folder from your server
11. Update the "system" module from the modules administration interface, other modules are recommended to update as well


Upgrading a non UTF-8 site:
UTF-8 encoding has been introduced into XOOPS 2.3 as default charset. However, there might be some problems with converting existent websites from non UTF-8 charset to UTF-8.
Before there is a good enough solution for this conversion, following settings are recommended when you upgrade an existent website if you are not an experienced user:
- Select "Do not change" option in "Database character set and collation" step during upgrade process
- Modify /languages/yourlanguage/global.php to use existent _CHARSET value if it has been changed to UTF-8 in your new global.php file as

define('_CHARSET', 'UTF-8');



Upgrading XoopsEditor package:
In the XOOPS 2.3.1 package, there are five editors included: dhtmltextarea and textarea for plain text, fckeditor, tinymce and koivi for WYSIWYG HTML.
Since there are some directory structure changes in both fckeditor and tinymce editors, you are recommended to remove existent editors before uploading the new additors.
And if you are using fckeditor for modules, please modify module specific configs following the files in /fckeditor/modules/, especially if you use "article" module.


Modules
-----------------------------------

This release contains only the "system-related modules". You are invited to browse the XOOPS modules repository to if you need additional functionality. Note: as a new repository is being built, the current repository is not up-to-date, PLEASE VISIT INDIVIDUAL DEVELOPERS' WEBSITES TO MAKE SURE YOU ARE USING LATEST VERSION OF MODULES.




Otras noticias
10/6/2016 4:21:05 - XOOPS 2.5.8 Final Español
14/10/2014 16:50:00 - Tutorial 1: Adaptando Plantillas HTML y CSS a XOOPS
23/6/2014 5:30:00 - Lanzamiento de XOOPS 2.5.7 Final
8/7/2013 3:40:00 - Diseño Web Adaptativo (Responsive Web Design)
21/6/2013 7:16:21 - Cambio de servidor

Los usuarios son responsables de sus propios comentarios.

Autor Hilo
drakko
Enviado: 28/11/2008 16:42  Actualizado: 28/11/2008 16:42
Equipo de esXOOPS
Conectado: 19/11/2002
Desde:
Envíos: 248
 XOOPS 2.3.2a - Security Release
solo actualizando.

Los archivos en español siguen siendo los mismos de la 2.31, no cambio nada en el idioma


El Equipo de Desarrollo XOOPS está contento de anunciar la liberación de XOOPS 2.3.2a

Esta liberación es únicamente para un par de arreglos de seguridad críticos, incluso una vulnerabilidad XSS reportada por el Grupo de Investigación Digital, vulnerabilidad de inclusión de archivo local potencial reportada por DSG, error de programación de Autoentrada al sistema reportado por Dylian y un error de programación atrasado en la sincronización de datos reportada por boy0917.

A Todos los usuarios de XOOPS 2.3.x es muy recomendable actualizar a esta versión cuanto antes.

Las versiones XOOPS 2.0 y 2.2 no son vulnerables a las cuestiones de seguridad reportadas aquí. Sin embargo, a los usuarios 2.0 y 2.2 usuarios que tienen instalado el módulo de Protector les aconsejan mejorar a la versión incluida en este paquete.

Descargar del repositorio de sourceforge
https://sourceforge.net/project/showfi ... =153583&release_id=643010

Autor Hilo
karlitamx
Enviado: 10/11/2008 22:49  Actualizado: 10/11/2008 22:49
Normal
Conectado: 18/10/2007
Desde:
Envíos: 92
 Re: Xoops 2.3.1 Final ¿puedo pasar xoops 2.08 a 2.31?
¿puedo pasar xoops 2.08 a 2.31?

al guien puede decirme en donde estan las instrucciones en español para actualizar mi xoops? gracias... saludos

Autor Hilo
josespi
Enviado: 4/11/2008 19:05  Actualizado: 4/11/2008 19:05
Equipo de esXOOPS
Conectado: 21/10/2004
Desde: Lima - Perú
Envíos: 656
 Re: Xoops 2.3.1 Final
Hola Negrolder:
La versión 2.3.1 es una versión estable. Me parece que tu problema es de adaptación a la nueva visualización de la información. A la izquierda debe aparecerte la lista de módulos instalados... si es una instalación nueva te aparecer Sistema... si presionas ahí entonces se abre la lista de opciones donde encontraras Modulos, para instalar los nuevos módulos que necesites.

José Espinoza

Autor Hilo
negrolder
Enviado: 29/10/2008 3:40  Actualizado: 29/10/2008 4:15
Principiante
Conectado: 19/10/2002
Desde: Santiago de Chile
Envíos: 28
 Re: Xoops 2.3.1 Final
Una consulta ¿Xoops 2.3.1 es utilizable para sitios productivos o todavía es de prueba?

Pues sucede que lo bajé, seguí cuidadosamente todas las indicaciones pero al pinchar en "Aministración" obtengo una pantalla que solo me muestra "Información de sistema" y "Extensiones PHP cargadas", pero no hay un "opciones" o "módulos" o "preferencias". Lo más parecido es un link que dice panel de control, pero me lleva a la misma página.

No sé si hice algo malo, pero seguí todas las instrucciones.

Gracias.

Autor Hilo
debianus
Enviado: 15/10/2008 22:55  Actualizado: 15/10/2008 22:55
Supremo
Conectado: 21/12/2006
Desde:
Envíos: 496
 Re: Xoops 2.3.1 Final
Iesesi: el problema supongo que estará causado porque el script de actualización no realiza adecuadamente la conversión de las bases de datos de latinxxx a utf8. Es mejor dejar la misma codificación que se tenga en uso en la página.
Para pasarla a utf8 prueba en un servidor local lo siguiente:
Actualiza sin cambiar la codificación de la base de datos
con phpmyadmin descarga una copia de la misma
Si el archivo no tiene la codificación utf-8, se convierte a ella (en Linux, iconv)
Lo abres con un editor de texto, buscar y reemplazar latinxxx por utf8. Depende de lo que se use a la hora de elegir la forma de hacer el reemplazo.
Eliminas todas las tablas de la base de datos
importas en ella el archivo que cambiaste
sube entonces al servidor los archivos de lenguaje con la codificación utf-8 (si usas archivos iso, con cambiar global.php no sirve de nada)
Claro que haran falta que los archivos de lenguaje de todos los módulos que uses tengan la misma codificación.

Esto debería funcionar, pero mejor prueba antes en un servidor local usando una copia de seguridad. Si funciona, sólo tendrías que subir la copia de la base de datos al servidor.

Autor Hilo
lesesi
Enviado: 15/10/2008 2:38  Actualizado: 15/10/2008 13:12
Supremo
Conectado: 10/7/2004
Desde: Argentina
Envíos: 670
 Re: Xoops 2.3.1 Final
Ya tengo actualizado a 2.3.1. Pero sigo teniendo problemas con los acentos y ñ s.
Consulta
Deberia bajar "Paquete del idioma Español en UTF-8" ?
(editado ya que no es un foro)
Instalé de 0 el 2.3 y como tenía problemas de acentos puse la actualización. a 2.3.1. Entonces voy a poner el el global iso y busco y reemplazo uf8 x iso. Probaré.
Gracias

Respuestas Autor Enviado
 Re: Xoops 2.3.1 Final riosoft 15/10/2008 7:31
 Re: Xoops 2.3.1 Final zeroram 9/11/2008 8:29