Fork me on GitHub
Fork me on GitHub
Donar Ahora!
Seleccione una cantidad para donar


¿Quiere que su nombre de usuario sea revelado con su donación?
Si - Listeme como un geneoso donante
No - Liste mi donación como un donante anónimo


Usuario
Bienvenido
Haz click para registrarte. Es gratuito y podrás utilizar todos los recursos de la web

Login

Recuerdame

¿Perdió su contraseña?


Online
Conectados: 16
Miembros: 0
Invitados: 14
Buscadores: 2

Estadísticas
Nuevos miembros: [BillyStilw-25/10/2017] [Teacher194-24/10/2017] [TimmyAngel-18/10/2017] [Leblanc-18/10/2017] [HealthyNut-17/10/2017] [HalliePerk-12/10/2017] [ShadBlais-8/10/2017] [WilburCruc-1/10/2017] [Ulanowski7-25/9/2017] [KaleyKlem-23/9/2017]
Registrados: 30176
Hoy: 0
Ayer: 0

Conectados:
onlineInvitadoForos
onlineInvitadoForos
usInvitadoForos
usInvitadoForos
usInvitadoDescargas Módulos (actual)
usInvitadoForos
usInvitadoForos
onlineInvitadoForos
usInvitadoForos
usInvitadoForos
usInvitadoForos
usInvitadoForos
onlineInvitadoForos
onlineInvitadoForos


Navegando en este tema:   1 Los usuarios anónimos




(1) 2 3 »


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#22
Nuevito
Info
gracias amigos....segui tus pasos y sencillamente pude poner los acentos en new.... vere si resiste a modulos tambien ... graciuas y un abrazo !!!!

Enviado el:2/4/2010 21:17
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#21
Nuevito
Info
Muchas gracias por tu aportacion, yo tenia el mismo problema y ya esta solucionado.

Saludos

Enviado el:25/5/2009 17:22
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#20
Principiante
Info
Gracias. Con esa simple modificacion se ha solucionado el problema. Muchas gracias.

Enviado el:1/5/2009 16:50
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#19
Nuevito
Info
bueno, pego el post que habia puesto en el hilo que comentaba antes, (lo mismo ati tambien te funciona, o no)


Hola, me presento soy Juan , es la primera vez que escribo aquí, tenia un problema con xoops, la versión que tengo instalada es la 2.3.3 en local con wampserver, pues bien me e vuelto loco se me borraba de terminado texto pensando que seria problema del modulo o configuración , probé todos los módulos de contenido que e pillado y todos hacían lo mismo hasta ke medí cuenta que el texto faltante era con los acentos y ñ, sin embargo en ingles no había problema. Bueno no voy a contar mi odisea que asido muy laaarga, hasta había tirado la toalla, “ya estaba haciendo pruebas con joomla y imprescms”. En fin me vuelto loco buscando información por todos lados la información esta “hay fuera”  pero creo que no esta de forma clara para novatos como yo.
Solución al problema fácil:
Ruta donde tienes instalado tu xoops con la carpeta lenguaje:
htdocs\language\spanish
en esa carpeta esta el archivo (global.php)
buscamos: define('_CHARSET','ISO-8859-1'); (que esta en la linea 205)
esa línea tiene ke poner ISO-8859-1
Ahora editamos el archivo (mainfile.php) que se encuentra en la ruta \htdocs
Buscamos: define( 'XOOPS_DB_CHARSET', 'UTF-8' ) (que esta en la linea 66)
Y cambiamos UTF-8 por ISO-8859-1

A lo mejor lo e complicado mas jeje.

PD: no se porque cambiándolo todo a UTF-8, ya no se me borra el texto pero los acentos salen sustituidos por un cuadradito si embargo en ingles sale bien y esta en UTF-8


saludos.

Enviado el:28/4/2009 18:52
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#18
Nuevito
Info
si muy bonito utilizar utf-8, el problema es que como le pido a un usuario que hace un post en un foro que si va a poner tilde lo reemplace por el equivalente utf-8?, la unica solucion viable que veo es una funcion que me reemplaze los caracteres por el equivalente utf-8 antes de grabarlos en la base de datos.

Enviado el:28/4/2009 17:30
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#17
Nuevito
Info
hola donsilencio, mirate el post que puesto en "[solucionado] no puedo poner acentos y la letra ñ", yo tenia el mismo problema y lo arreglado asi. No creo que sea problema del cotejamien en la base datos por ke yo los e puesto casi todos y no se solucionaba a demas si escribia directamente en la tabla de BD con phpmyadmin ponia acentos y no se borraban, pero luego al ver el articulo desde el xoops sustituia los acentos por caracteres estraños pero ya no se borraban, ahora puesto el xoops en ISO-8859-1 y el cotejamiento de la BD lo mismo lo pongo en UTF-8 que UTF-spanis y funciona igual. bueno kizas no porke si activo el debug en linea del xoops, medice que no encuentra ISO-8859-1 en la BD, pero funciona.
creo que el problema esta en que la instalacion la realiza en UTF-8 por defecto porke el idioma igles viene en UTF-8 y la carpeta del idioma español esta en ISO

Enviado el:27/4/2009 22:35
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#16
Principiante
Info
Por cierto, el que instale era el 2.3.3 ISO.

Enviado el:27/4/2009 21:44
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#15
Principiante
Info
Acotación:

aixos escribió:


Yo no entiendo porque , al instalar no poneis el ISO,
¿Es por algo ?


No, no es por nada, basicamente por que no sabia que iba a tener este problema, es la primera vez que me pasa, de haberlo sabido lo hubiese hecho.

Por cierto, con el Latin1_spanish_ci ya lo he intentado, y no funciona.

Hay manera de solucionarlo?

Enviado el:27/4/2009 20:07
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#14
Equipo de esXOOPS
Info
hola
el cotejamiento es :
latin1_spanish_ci

Yo no entiendo porque , al instalar no poneis el ISO,
¿Es por algo ?
Este paso es muy imporatante el de elegir el ISO y latin
O sea la gente lo instala en UTF8 y luego quiere cambiar todo.

Ojo , cuando se intala por primera vez ISO , ya lo puse en otro post
y no tendreis follones.

Enviado el:27/4/2009 19:56
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Xoops se come eñes y signos de exclamación/interrogación, pero no tildes
#13
Principiante
Info
Muy buenas. Estoy con el mismo problema y no consigo solucionarlo tal como decis.

Al escribir en el foro o en el contenido de un bloque, tras poner una ñ o acento se borra el texto desde ese simbolo.

He provado con latin1 y nada, tampoco. Tambien con utf8_unicode, utf8_spanish_ci, utf8_spanish2_ci y nada.

Estos son mis datos:

XOOPS 2.3.3
# Versión del servidor: 5.0.41-log
# Servidor: mysql04
# Juegos de caracteres de MySQL: UTF-8 Unicode (utf8)
www.corazonmotero.com .

Por cierto. Revisando la base de datos, me encuentro esto:

Haga Clic para ver la Imagen original en una ventana nueva


Ese Latin1_swedish_ci no tendra algo que ver? Y si es asi, como cambiarlo?

Os doy las gracias de antemano.

Enviado el:27/4/2009 19:19
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati







Usted puede ver temas.
No puede empezar un nuevo tema.
No puede responder mensajes.
Usted no puede editar sus mensajes.
Usted no puede borrar sus mensajes.
Usted no puede crear encuestas.
Usted no puede votar en encuestas.
No se pueden adjuntar archivos a los mensajes.
No se puede publicar sin aprobación.
Usted no puede usar el tipo de tema.
Usted no puede utilizar la sintaxis HTML.
No se puede utilizar firma.

[Búsqueda Avanzada]


Mensajes Recientes

Foro Tema Respuestas Visitas Último Mensaje