Fork me on GitHub
Fork me on GitHub
Donar Ahora!
Seleccione una cantidad para donar


¿Quiere que su nombre de usuario sea revelado con su donación?
Si - Listeme como un geneoso donante
No - Liste mi donación como un donante anónimo


Usuario
Bienvenido
Haz click para registrarte. Es gratuito y podrás utilizar todos los recursos de la web

Login

Recuerdame

¿Perdió su contraseña?


Online
Conectados: 16
Miembros: 0
Invitados: 16
Buscadores: 0

Estadísticas
Nuevos miembros: [BillyStilw-25/10/2017] [Teacher194-24/10/2017] [TimmyAngel-18/10/2017] [Leblanc-18/10/2017] [HealthyNut-17/10/2017] [HalliePerk-12/10/2017] [ShadBlais-8/10/2017] [WilburCruc-1/10/2017] [Ulanowski7-25/9/2017] [KaleyKlem-23/9/2017]
Registrados: 30176
Hoy: 0
Ayer: 0

Conectados:
onlineInvitadoNoticias
onlineInvitadoForos
onlineInvitadoForos
onlineInvitadoForos
usInvitadoNoticias
onlineInvitadoForos
onlineInvitadoForos
onlineInvitadoForos
onlineInvitadoForos
onlineInvitadoForos
onlineInvitadoTitulares
onlineInvitadoForos
onlineInvitadoForos
onlineInvitadoForos
onlineInvitadoForos
usInvitadoForos


Navegando en este tema:   1 Los usuarios anónimos






Re: Problemas instalación local con Ubuntu
#6
Administrador
Info
Pues no parece que sea problema de la base de datos.
Supongo que si no tuvieras permisos correctos, no te dejaría meter datos en ninguna tabla. Por tanto no podrías subir News nuevas...

(Estoy pensando en alto )

¿Puedes subir los archivos de módulos nuevos a .../www/ como usuario normal, sin tirar de sudo?

Si te deja, Ya me quedo descolocado...
A mí lo único que se me ocurre es permisos de escritura o ejecución...

¿Has probado con otros módulos nuevos y no te deja con ninguno?

¿Has probado a subirlos con sudo, haciendo un sudo cp?

Enviado el:11/2/2008 14:41
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Problemas instalación local con Ubuntu
#5
Principiante
Info
Bueno, tengo que decir que no lo instalé de cero, lo que hice fue copiar la estructura de directorios existente en el servidor web a local, luego con las tablas de la BD igual. Modifiqué los datos pertinentes en mainfile.php y dí permisos de escritura en Templates, cache y uploads.

Todo me funciona perfectamente e incluso puedo crear noticias nuevas y mensajes en los foros. Pero por ahora, lo único que me falla es la instalación de nuevos módulos.

Lo que puedo hacer es intentar instalar todo desde cero en localhost para ver si así funciona, porque otra cosa no se me ocurre y googleando no he encontrado nada al respecto.

De todas maneras, gracias por la ayuda.

Saludos

Enviado el:7/2/2008 22:34
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Problemas instalación local con Ubuntu
#4
Administrador
Info
Ayer leí tu post a toda pastilla, y no muy bien, creo.
Y además lo que te dije, lo hice instalando Xammp... o sea que no te vale de mucho...

Dices que la instalación fue muy bien.
Eso quiere decir que efectivamente, has podido meter archivos en (tu caso) /var/www/ e instalar un xoops vía navegador. Y ha funcionado.

Eso indicaría que es posible que no sea problema de permisos en cuanto a archivos...

En cualquier caso, /var/www/ y todos los subdirectorios se tienen que poder leer/ejecutar por cualquiera (otros o todos los usuarios) además de que cache etc, sean escribibles...

Menú inicio no es un archivo físico, entiendo, sino configuraciones en la base de datos, luego creo que lo que quiere decir es que no tiene permisos para escribir en la base de datos. Sin embargo tiene acceso, pues si llegas a la pantalla de módulos, accede y lee la BD.

El usuario que tengas puesto en el mainfile, debe tener permisos para insertar actualizar la base de datos MySql, no sólo para leer.

Supongo que si intentas crear un bloque personalizado, te saldrá algo parecido... o si intentas insertar una noticia...

Si te deja crear el bloque, y todo lo anterior es correcto, no se me ocurre más por ahora.

Enviado el:7/2/2008 9:53
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Problemas instalación local con Ubuntu
#3
Principiante
Info
El directorio /opt me aparece completamente vacío. Todo el tema de estructura de directorios de la página web se monta en /var/www

He probado entonces lo del nobody sin ningún resultado, lo del htdocs no lo he podido hacer ya que no encuentro el archivo por ningún sitio. Haré más pruebas

Gracias

Enviado el:7/2/2008 8:15
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Re: Problemas instalación local con Ubuntu
#2
Administrador
Info
Me pasó algo parecido cuando monté el Xampp.
No recuerdo los mensajes, lo arreglé otorgando permisos. A ver si tengo algo...

Tema, que tienes que tener permisos de lectura/escritura en htdocs (para propietario y al menos lectura para Otros), por lo menos. Me refiero a ~/lampp/htdocs/

Lo primero (he encontrado mis notas):

Hay un problema con los permisos para ejecutar php, etc

Hay propuestas varias soluciones:

  • A todos los archivos bajo /opt/lampp cambiar propietario a nobody, ya que Apache espera que sea nobody el usuario. En principio funciona bien, pero luego, para ver el http://localhost/xampp da problemas. Pide contraseña y no he sido capaz de arreglar.
    Incluso hay un script en un foro de ubuntu.es
  • He probado a cambiar /opt/lampp/etc/httpd.conf, el archivo de configuración de apache y poner root como usuario y grupo. No parece que haya arreglado nada (elijo root porque es el propietario de lib y archivos en su mayoría.
  • Otra opción: cambiar permisos a 777 a todo /opt/lampp. Funciona, es una locura en términos de seguridad, pero funciona.


He probado las tres.

La del medio, parecía no chutar, He vuelto a hacer la prueba y no arranca nada. Usuario debe ser nobody.

He hecho la tercera y no ha funcionado al final.
Por tanto, lo que hay que hacer es poner nobody a todos los archivos de lampp. No uses el script. Pone nobody a todo hijo de vecino.
Comandos:

sudo chown nobody -R /opt/lampp/
# la opción -R es para que afecte a todos subdirectorios y archivos, si no sólo cambiaría el directorio lampp.

Después, hay que poner 777 a htdocs, porque si no no deja escribir.

sudo chmod 777 /opt/lampp/htdocs/

Sólo a htdocs.
No es problema que Xampp/ pertenezca o tenga otros servicios.

................................................................................................

Prueba con esto, y luego vuelve a probar (quizás debas sobreescribir el sitio local xoops)

Un saludo

Enviado el:6/2/2008 19:29
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati


Problemas instalación local con Ubuntu
#1
Principiante
Info
Hola

Para evitarme problemas, he decidido instalarme una copia de mi xoops en local mediante un Servidor Lamp en Ubuntu.

La instalación ha sido fácil y rápida y ya tengo la web en funcionamiento con los permisos de las carpetas templates_c, cache y uploads. El problema me viene cuando quiero instalar un nuevo módulo para testearlo. Cuando le doy a instalar me aparece el siguiente mensaje (ejemplo hecho con el módulo weblinks):

Imposible Instalar weblinksError(es):

Imposible Escribir en el menú de principal.

Regresar a la página de administración de módulos


Parece que sea un problema de que no tiene permisos para escribir en la base de datos. ¿Alguna idea para solucionarlo?

Saludos y gracias de antemano

Enviado el:6/2/2008 17:31
Crear PDF con el mensaje Imprimir Facebook Twitter Google Buzz Linkedin Stumbleupon FriendFeed Del.icio.us Digg Reddit Technorati







Usted puede ver temas.
No puede empezar un nuevo tema.
No puede responder mensajes.
Usted no puede editar sus mensajes.
Usted no puede borrar sus mensajes.
Usted no puede crear encuestas.
Usted no puede votar en encuestas.
No se pueden adjuntar archivos a los mensajes.
No se puede publicar sin aprobación.
Usted no puede usar el tipo de tema.
Usted no puede utilizar la sintaxis HTML.
No se puede utilizar firma.

[Búsqueda Avanzada]


Mensajes Recientes

Foro Tema Respuestas Visitas Último Mensaje